XML External Entity (XXE) Injection in Apache Solr
CVE-2019-0193GHSA-3gm7-v7vw-866c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 8.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-core
- Affected
- < 8.2.0
- Fixed in
- 8.2.0
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-0193 to the Known Exploited Vulnerabilities catalog on 2021-12-10.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2021-12-10).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3gm7-v7vw-866c lists affected ranges: Maven org.apache.solr:solr-core >=0 <8.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:H
- EPSS
- CVE-2019-0193: 83.55% estimated exploitation activity in the next 30 days; percentile 99.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Solr, the DataImportHandler, an optional but popular module to pull in data from databases and other sources, has a feature in which the whole DIH configuration can come from a request's "dataConfig" parameter. The debug mode of the DIH admin screen uses this to allow convenient debugging / development of a DIH config. Since a DIH config can contain scripts, this parameter is a security risk. Starting with version 8.2.0 of Solr, use of this parameter requires setting the Java System property "enable.dih.dataConfigParam" to true.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3gm7-v7vw-866c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-0193 Advisory: XML External Entity (XXE) Injection in Apache Solr IDs: CVE-2019-0193, GHSA-3gm7-v7vw-866c Record: https://patchnext.com/advisories/cve-2019-0193 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 8.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-core: affected < 8.2.0; fixed in 8.2.0 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-0193 to the Known Exploited Vulnerabilities catalog on 2021-12-10.) - Verified: https://github.com/advisories/GHSA-3gm7-v7vw-866c (GitHub-reviewed advisory GHSA-3gm7-v7vw-866c lists affected ranges: Maven org.apache.solr:solr-core >=0 <8.2.0) Commands are suggestions: review each one before running it.
Loading voting…