XML External Entity injection in Apache Camel
CVE-2019-0188GHSA-h896-mx9x-g32g
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-xmljson
- Affected
- <= 2.23.4
- Fixed in
- no fixed version recorded
Maven org.apache.camel:camel-core
- Affected
- < 2.24.0
- Fixed in
- 2.24.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h896-mx9x-g32g lists affected ranges: Maven org.apache.camel:camel-core >=0 =0 <=2.23.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-0188: 9.78% estimated exploitation activity in the next 30 days; percentile 95.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability (CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson component, which was removed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h896-mx9x-g32g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-0188 Advisory: XML External Entity injection in Apache Camel IDs: CVE-2019-0188, GHSA-h896-mx9x-g32g Record: https://patchnext.com/advisories/cve-2019-0188 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.camel:camel-core 2.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-xmljson: affected <= 2.23.4 - Maven org.apache.camel:camel-core: affected < 2.24.0; fixed in 2.24.0 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-xmljson: check the installed version with your package manager. - Maven org.apache.camel:camel-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-xmljson, org.apache.camel:camel-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h896-mx9x-g32g (GitHub-reviewed advisory GHSA-h896-mx9x-g32g lists affected ranges: Maven org.apache.camel:camel-core >=0 =0 <=2.23.4) Commands are suggestions: review each one before running it.
Loading voting…