Skip to content

← Actionable
Critical, CVSS 9.1

elFinder Path Traversal vulnerability

CVE-2018-9109GHSA-45x3-mw7q-wf7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (studio-42/elfinder 2.1.36), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2018-9109: 2.94% estimated exploitation activity in the next 30 days; percentile 87.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in elFinder.class.php with the zipdl() function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-45x3-mw7q-wf7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-9109

Advisory: elFinder Path Traversal vulnerability
IDs: CVE-2018-9109, GHSA-45x3-mw7q-wf7f
Record: https://patchnext.com/advisories/cve-2018-9109 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: studio-42/elfinder 2.1.36. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist studio-42/elfinder: affected < 2.1.36; fixed in 2.1.36

## Suggested inspection (read-only)
- Packagist studio-42/elfinder: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on studio-42/elfinder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-45x3-mw7q-wf7f (GitHub-reviewed advisory GHSA-45x3-mw7q-wf7f lists affected ranges: Packagist studio-42/elfinder >=0 <2.1.36)

Commands are suggestions: review each one before running it.

Loading voting…