HashiCorp Terraform Amazon Web Services (AWS) uses an insecure PRNG
CVE-2018-9057GHSA-r48h-jr2j-9g78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/terraform-provider-aws 1.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/terraform-provider-aws
- Affected
- < 1.14.0
- Fixed in
- 1.14.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r48h-jr2j-9g78 lists affected ranges: Go github.com/hashicorp/terraform-provider-aws >=0 <1.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-9057: 1.92% estimated exploitation activity in the next 30 days; percentile 79.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
aws/resourceawsiamuserloginprofile.go in the HashiCorp Terraform Amazon Web Services (AWS) provider through v1.12.0 has an inappropriate PRNG algorithm and seeding, which makes it easier for remote attackers to obtain access by leveraging an IAM account that was provisioned with a weak password.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r48h-jr2j-9g78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-9057 Advisory: HashiCorp Terraform Amazon Web Services (AWS) uses an insecure PRNG IDs: CVE-2018-9057, GHSA-r48h-jr2j-9g78 Record: https://patchnext.com/advisories/cve-2018-9057 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/terraform-provider-aws 1.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/terraform-provider-aws: affected < 1.14.0; fixed in 1.14.0 ## Suggested inspection (read-only) - Go github.com/hashicorp/terraform-provider-aws: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/terraform-provider-aws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r48h-jr2j-9g78 (GitHub-reviewed advisory GHSA-r48h-jr2j-9g78 lists affected ranges: Go github.com/hashicorp/terraform-provider-aws >=0 <1.14.0) Commands are suggestions: review each one before running it.
Loading voting…