Plaintext Storage of Sensitive Information in Laravel Log Viewer before v0.13.0
CVE-2018-8947GHSA-63qj-p8gh-5xxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rap2hpoutre/laravel-log-viewer 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist rap2hpoutre/laravel-log-viewer
- Affected
- < 0.13.0
- Fixed in
- 0.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63qj-p8gh-5xxx lists affected ranges: Packagist rap2hpoutre/laravel-log-viewer >=0 <0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-8947: 11.02% estimated exploitation activity in the next 30 days; percentile 95.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
rap2hpoutre Laravel Log Viewer before v0.13.0 relies on Base64 encoding for l, dl, and del requests, which makes it easier for remote attackers to bypass intended access restrictions, as demonstrated by reading arbitrary files via a dl request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-63qj-p8gh-5xxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8947 Advisory: Plaintext Storage of Sensitive Information in Laravel Log Viewer before v0.13.0 IDs: CVE-2018-8947, GHSA-63qj-p8gh-5xxx Record: https://patchnext.com/advisories/cve-2018-8947 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rap2hpoutre/laravel-log-viewer 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist rap2hpoutre/laravel-log-viewer: affected < 0.13.0; fixed in 0.13.0 ## Suggested inspection (read-only) - Packagist rap2hpoutre/laravel-log-viewer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rap2hpoutre/laravel-log-viewer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-63qj-p8gh-5xxx (GitHub-reviewed advisory GHSA-63qj-p8gh-5xxx lists affected ranges: Packagist rap2hpoutre/laravel-log-viewer >=0 <0.13.0) Commands are suggestions: review each one before running it.
Loading voting…