Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in loofah

CVE-2018-8048GHSA-x7rv-cr6v-4vm4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.8.3; loofah 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    < 1.8.3
    Fixed in
    1.8.3
  • RubyGems loofah

    Affected
    < 2.2.1
    Fixed in
    2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-8048: 1.93% estimated exploitation activity in the next 30 days; percentile 79.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Loofah allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments. Users are affected if running Loofah < 2.2.1, but only: when running on MRI or RBX, in combination with libxml2 = 2.9.2. JRuby users are not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x7rv-cr6v-4vm4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-8048

Advisory: Cross-site Scripting in loofah
IDs: CVE-2018-8048, GHSA-x7rv-cr6v-4vm4
Record: https://patchnext.com/advisories/cve-2018-8048 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.8.3; loofah 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected < 1.8.3; fixed in 1.8.3
- RubyGems loofah: affected < 2.2.1; fixed in 2.2.1

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.
- RubyGems loofah: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri, loofah.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x7rv-cr6v-4vm4 (GitHub-reviewed advisory GHSA-x7rv-cr6v-4vm4 lists affected ranges: RubyGems loofah >=0 =0 <1.8.3)

Commands are suggestions: review each one before running it.

Loading voting…