Apache Camel's Mail is vulnerable to path traversal
CVE-2018-8041GHSA-jv74-f9pj-xp3f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-mail 2.22.1, 2.21.2, 2.20.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-mail
- Affected
- >= 2.20.0, < 2.20.4>= 2.21.0, < 2.21.2>= 2.22.0, <= 2.22.0
- Fixed in
- 2.22.1, 2.20.4, 2.21.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jv74-f9pj-xp3f lists affected ranges: Maven org.apache.camel:camel-mail >=2.20.0 =2.21.0 =2.22.0 <=2.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2018-8041: 9.59% estimated exploitation activity in the next 30 days; percentile 95.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Camel's Mail 2.20.0 through 2.20.3, 2.21.0 through 2.21.1 and 2.22.0 is vulnerable to path traversal.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jv74-f9pj-xp3f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8041 Advisory: Apache Camel's Mail is vulnerable to path traversal IDs: CVE-2018-8041, GHSA-jv74-f9pj-xp3f Record: https://patchnext.com/advisories/cve-2018-8041 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-mail 2.22.1, 2.21.2, 2.20.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-mail: affected >= 2.20.0, < 2.20.4; >= 2.21.0, < 2.21.2; >= 2.22.0, <= 2.22.0; fixed in 2.22.1, 2.20.4, 2.21.2 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-mail: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-mail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jv74-f9pj-xp3f (GitHub-reviewed advisory GHSA-jv74-f9pj-xp3f lists affected ranges: Maven org.apache.camel:camel-mail >=2.20.0 =2.21.0 =2.22.0 <=2.22.0) Commands are suggestions: review each one before running it.
Loading voting…