Privilege escalation vulnerability in Apache Hadoop
CVE-2018-8029GHSA-37pw-qw47-4jxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-main 3.1.1, 2.9.2, 2.8.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-main
- Affected
- >= 2.2.0, < 2.8.4>= 2.9.0, < 2.9.2>= 3.0.0, < 3.1.1
- Fixed in
- 3.1.1, 2.9.2, 2.8.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-37pw-qw47-4jxm lists affected ranges: Maven org.apache.hadoop:hadoop-main >=2.2.0 =2.9.0 =3.0.0 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-8029: 3.91% estimated exploitation activity in the next 30 days; percentile 90.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-37pw-qw47-4jxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8029 Advisory: Privilege escalation vulnerability in Apache Hadoop IDs: CVE-2018-8029, GHSA-37pw-qw47-4jxm Record: https://patchnext.com/advisories/cve-2018-8029 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-main 3.1.1, 2.9.2, 2.8.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-main: affected >= 2.2.0, < 2.8.4; >= 2.9.0, < 2.9.2; >= 3.0.0, < 3.1.1; fixed in 3.1.1, 2.9.2, 2.8.4 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-main: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-main. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-37pw-qw47-4jxm (GitHub-reviewed advisory GHSA-37pw-qw47-4jxm lists affected ranges: Maven org.apache.hadoop:hadoop-main >=2.2.0 =2.9.0 =3.0.0 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…