There is a XML external entity expansion (XXE) vulnerability in Apache Solr config files
CVE-2018-8010GHSA-rc9v-h28f-jcmf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 7.3.1, 6.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-core
- Affected
- >= 6.6.0, < 6.6.4>= 7.0.0, < 7.3.1
- Fixed in
- 7.3.1, 6.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rc9v-h28f-jcmf lists affected ranges: Maven org.apache.solr:solr-core >=6.6.0 =7.0.0 <7.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-8010: 3.71% estimated exploitation activity in the next 30 days; percentile 89.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This vulnerability in Apache Solr 6.0.0 to 6.6.3, 7.0.0 to 7.3.0 relates to an XML external entity expansion (XXE) in Solr config files (solrconfig.xml, schema.xml, managed-schema). In addition, Xinclude functionality provided in these config files is also affected in a similar way. The vulnerability can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network. Users are advised to upgrade to either Solr 6.6.4 or Solr 7.3.1 releases both of which address the vulnerability. Once upgrade is complete, no other steps are required. Those releases only allow external entities and Xincludes that refer to local files / zookeeper resources below the Solr instance directory (using Solr's ResourceLoader); usage of absolute URLs is denied. Keep in mind, that external entities and XInclude are explicitly supported to better structure config files in large installations. Before Solr 6 this was no problem, as config files were…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rc9v-h28f-jcmf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-8010 Advisory: There is a XML external entity expansion (XXE) vulnerability in Apache Solr config files IDs: CVE-2018-8010, GHSA-rc9v-h28f-jcmf Record: https://patchnext.com/advisories/cve-2018-8010 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 7.3.1, 6.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-core: affected >= 6.6.0, < 6.6.4; >= 7.0.0, < 7.3.1; fixed in 7.3.1, 6.6.4 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rc9v-h28f-jcmf (GitHub-reviewed advisory GHSA-rc9v-h28f-jcmf lists affected ranges: Maven org.apache.solr:solr-core >=6.6.0 =7.0.0 <7.3.1) Commands are suggestions: review each one before running it.
Loading voting…