Skip to content

← Actionable
High, CVSS 8.8

Path Traversal in Hadoop

CVE-2018-8009GHSA-6x48-j4x4-cqw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-main 3.1.1, 3.0.3, 2.9.2, 2.8.5, 2.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.hadoop:hadoop-main

    Affected
    >= 3.1.0, <= 3.1.0>= 3.0.0, < 3.0.3>= 2.9.0, < 2.9.2>= 2.8.0, < 2.8.5< 2.7.7
    Fixed in
    2.7.7, 3.1.1, 2.9.2, 3.0.3, 2.8.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-8009: 6.73% estimated exploitation activity in the next 30 days; percentile 93.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Hadoop 3.1.0, 3.0.0-alpha to 3.0.2, 2.9.0 to 2.9.1, 2.8.0 to 2.8.4, 2.0.0-alpha to 2.7.6, 0.23.0 to 0.23.11 is exploitable via the zip slip vulnerability in places that accept a zip file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6x48-j4x4-cqw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-8009

Advisory: Path Traversal in Hadoop
IDs: CVE-2018-8009, GHSA-6x48-j4x4-cqw3
Record: https://patchnext.com/advisories/cve-2018-8009 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-main 3.1.1, 3.0.3, 2.9.2, 2.8.5, 2.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.hadoop:hadoop-main: affected >= 3.1.0, <= 3.1.0; >= 3.0.0, < 3.0.3; >= 2.9.0, < 2.9.2; >= 2.8.0, < 2.8.5; < 2.7.7; fixed in 2.7.7, 3.1.1, 2.9.2, 3.0.3, 2.8.5

## Suggested inspection (read-only)
- Maven org.apache.hadoop:hadoop-main: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.hadoop:hadoop-main.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6x48-j4x4-cqw3 (GitHub-reviewed advisory GHSA-6x48-j4x4-cqw3 lists affected ranges: Maven org.apache.hadoop:hadoop-main >=3.1.0 =3.0.0 =2.9.0 =2.8.0 =0 <2.7.7)

Commands are suggestions: review each one before running it.

Loading voting…