Skip to content

← Actionable
High, CVSS 7.5

SimpleSAMLphp Improper Verification of Cryptographic Signature

CVE-2018-7644GHSA-923w-2xv2-7pr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2 3.1.3, 2.3.7, 1.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist simplesamlphp/saml2

    Affected
    < 1.10.5>= 2.0, < 2.3.7>= 3.0, < 3.1.3
    Fixed in
    1.10.5, 2.3.7, 3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2018-7644: 1.45% estimated exploitation activity in the next 30 days; percentile 73.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-923w-2xv2-7pr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7644

Advisory: SimpleSAMLphp Improper Verification of Cryptographic Signature
IDs: CVE-2018-7644, GHSA-923w-2xv2-7pr8
Record: https://patchnext.com/advisories/cve-2018-7644 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2 3.1.3, 2.3.7, 1.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/saml2: affected < 1.10.5; >= 2.0, < 2.3.7; >= 3.0, < 3.1.3; fixed in 1.10.5, 2.3.7, 3.1.3

## Suggested inspection (read-only)
- Packagist simplesamlphp/saml2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/saml2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-923w-2xv2-7pr8 (GitHub-reviewed advisory GHSA-923w-2xv2-7pr8 lists affected ranges: Packagist simplesamlphp/saml2 >=0 =2.0 =3.0 <3.1.3)

Commands are suggestions: review each one before running it.

Loading voting…