Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Drupal Core Remote Code Execution Vulnerability

CVE-2018-7602GHSA-297x-j9pm-xjgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.5.3, 8.4.8, 7.59; drupal/drupal 8.5.3, 8.4.8, 7.59), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0, < 7.59>= 8.0, < 8.4.8>= 8.5, < 8.5.3
    Fixed in
    7.59, 8.5.3, 8.4.8
  • Packagist drupal/drupal

    Affected
    >= 7.0, < 7.59>= 8.0, < 8.4.8>= 8.5, < 8.5.3
    Fixed in
    7.59, 8.5.3, 8.4.8

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2018-7602: 99.17% estimated exploitation activity in the next 30 days; percentile 99.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-297x-j9pm-xjgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7602

Advisory: Drupal Core Remote Code Execution Vulnerability
IDs: CVE-2018-7602, GHSA-297x-j9pm-xjgg
Record: https://patchnext.com/advisories/cve-2018-7602 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.5.3, 8.4.8, 7.59; drupal/drupal 8.5.3, 8.4.8, 7.59. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0, < 7.59; >= 8.0, < 8.4.8; >= 8.5, < 8.5.3; fixed in 7.59, 8.5.3, 8.4.8
- Packagist drupal/drupal: affected >= 7.0, < 7.59; >= 8.0, < 8.4.8; >= 8.5, < 8.5.3; fixed in 7.59, 8.5.3, 8.4.8

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2018-7602 to the Known Exploited Vulnerabilities catalog on 2022-04-13.)
- Verified: https://github.com/advisories/GHSA-297x-j9pm-xjgg (GitHub-reviewed advisory GHSA-297x-j9pm-xjgg lists affected ranges: Packagist drupal/core >=7.0 =8.0 =8.5 =7.0 =8.0 =8.5 <8.5.3)

Commands are suggestions: review each one before running it.

Loading voting…