Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Drupal Core Remote Code Execution Vulnerability

CVE-2018-7600GHSA-7fh9-933g-885p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.5.1, 8.4.6, 8.3.9, 7.58; drupal/drupal 8.5.1, 8.4.6, 8.3.9, 7.58), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0, < 7.58>= 8.0, < 8.3.9>= 8.4.0, < 8.4.6>= 8.5.0, < 8.5.1
    Fixed in
    8.3.9, 8.5.1, 8.4.6, 7.58
  • Packagist drupal/drupal

    Affected
    >= 7.0, < 7.58>= 8.0, < 8.3.9>= 8.4, < 8.4.6>= 8.5, < 8.5.1
    Fixed in
    8.3.9, 8.5.1, 8.4.6, 7.58

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2018-7600: 99.99% estimated exploitation activity in the next 30 days; percentile 99.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7fh9-933g-885p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7600

Advisory: Drupal Core Remote Code Execution Vulnerability
IDs: CVE-2018-7600, GHSA-7fh9-933g-885p
Record: https://patchnext.com/advisories/cve-2018-7600 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.5.1, 8.4.6, 8.3.9, 7.58; drupal/drupal 8.5.1, 8.4.6, 8.3.9, 7.58. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0, < 7.58; >= 8.0, < 8.3.9; >= 8.4.0, < 8.4.6; >= 8.5.0, < 8.5.1; fixed in 8.3.9, 8.5.1, 8.4.6, 7.58
- Packagist drupal/drupal: affected >= 7.0, < 7.58; >= 8.0, < 8.3.9; >= 8.4, < 8.4.6; >= 8.5, < 8.5.1; fixed in 8.3.9, 8.5.1, 8.4.6, 7.58

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2018-7600 to the Known Exploited Vulnerabilities catalog on 2021-11-03.)
- Verified: https://github.com/advisories/GHSA-7fh9-933g-885p (GitHub-reviewed advisory GHSA-7fh9-933g-885p lists affected ranges: Packagist drupal/core >=7.0 =8.0 =8.4.0 =8.5.0 =7.0 =8.0 =8.4 =8.5 <8.5.1)

Commands are suggestions: review each one before running it.

Loading voting…