AWS Lambda parser is vulnerable to Regular Expression Denial of Service
CVE-2018-7560GHSA-6jqp-j69q-pm62
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-lambda-multipart-parser 0.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm aws-lambda-multipart-parser
- Affected
- < 0.1.2
- Fixed in
- 0.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6jqp-j69q-pm62 lists affected ranges: npm aws-lambda-multipart-parser >=0 <0.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jqp-j69q-pm62 lists affected ranges: npm aws-lambda-multipart-parser >=0 <0.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-7560: 1.36% estimated exploitation activity in the next 30 days; percentile 71.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
index.js in the aws-lambda-multipart-parser NPM package before 0.1.2 has a Regular Expression Denial of Service (ReDoS) issue via a crafted multipart/form-data boundary string.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6jqp-j69q-pm62
- Revision 1 · created ·
Published from osv record GHSA-6jqp-j69q-pm62
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-7560 Advisory: AWS Lambda parser is vulnerable to Regular Expression Denial of Service IDs: CVE-2018-7560, GHSA-6jqp-j69q-pm62 Record: https://patchnext.com/advisories/cve-2018-7560 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aws-lambda-multipart-parser 0.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm aws-lambda-multipart-parser: affected < 0.1.2; fixed in 0.1.2 ## Suggested inspection (read-only) - `npm ls aws-lambda-multipart-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aws-lambda-multipart-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6jqp-j69q-pm62 (OSV record GHSA-6jqp-j69q-pm62 lists affected ranges: npm aws-lambda-multipart-parser >=0 <0.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6jqp-j69q-pm62 (GitHub-reviewed advisory GHSA-6jqp-j69q-pm62 lists affected ranges: npm aws-lambda-multipart-parser >=0 <0.1.2) Commands are suggestions: review each one before running it.
Loading voting…