Skip to content

← Actionable
Medium, CVSS 6.1

Yab Quarx persistent cross-site scripting vulnerability

CVE-2018-7274GHSA-h4fh-gpvh-753g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yab/quarx 2.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist yab/quarx

    Affected
    < 2.4.5
    Fixed in
    2.4.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-7274: 0.99% estimated exploitation activity in the next 30 days; percentile 62.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Yab Quarx before 2.4.5 is prone to multiple persistent cross-site scripting vulnerabilities: Blog (Title), FAQ (Question), Pages (Title), Widgets (Name), and Menus (Name).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h4fh-gpvh-753g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7274

Advisory: Yab Quarx persistent cross-site scripting vulnerability
IDs: CVE-2018-7274, GHSA-h4fh-gpvh-753g
Record: https://patchnext.com/advisories/cve-2018-7274 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yab/quarx 2.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yab/quarx: affected < 2.4.5; fixed in 2.4.5

## Suggested inspection (read-only)
- Packagist yab/quarx: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yab/quarx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h4fh-gpvh-753g (GitHub-reviewed advisory GHSA-h4fh-gpvh-753g lists affected ranges: Packagist yab/quarx >=0 <2.4.5)

Commands are suggestions: review each one before running it.

Loading voting…