Skip to content

← Actionable
Unrated

All versions of 9.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server…

CVE-2018-7162

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 10.4.1, 9.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 9.0.0, < 9.11.2>= 10.0.0, < 10.4.1
    Fixed in
    10.4.1, 9.11.2

Sources

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 50 lists CVE-2018-7162 affecting node >=9.0.0 =10.0.0 <10.4.1

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2018-7162 to 2018-06-12.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2018-7162: 6.64% estimated exploitation activity in the next 30 days; percentile 93.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All versions of 9.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation. Thanks to Jordan Zebor at F5 Networks all of his help investigating this issue with the Node.js team.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:50

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:50

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7162

Advisory: All versions of 9.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server…
IDs: CVE-2018-7162
Record: https://patchnext.com/advisories/cve-2018-7162 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 10.4.1, 9.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 9.0.0, < 9.11.2; >= 10.0.0, < 10.4.1; fixed in 10.4.1, 9.11.2

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/50.json (Node.js security working group core entry 50 lists CVE-2018-7162 affecting node >=9.0.0 =10.0.0 <10.4.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2018-7162 to 2018-06-12.)

Commands are suggestions: review each one before running it.

Loading voting…