All versions of 8.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be…
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 10.4.1, 9.11.2, 8.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 8.0.0, < 8.11.3>= 9.0.0, < 9.11.2>= 10.0.0, < 10.4.1
- Fixed in
- 10.4.1, 8.11.3, 9.11.2
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2018-7161 to 2018-06-12.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 49 lists CVE-2018-7161 affecting node >=8.0.0 =9.0.0 =10.0.0 <10.4.1
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2018-7161: 7.49% estimated exploitation activity in the next 30 days; percentile 94.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
All versions of 8.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be accomplished by interacting with the http2 server in a manner that triggers a cleanup bug where objects are used in native code after they are no longer available. This has been addressed by updating the http2 implementation. Thanks to Jordan Zebor at F5 Networks for reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:49
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-7161 Advisory: All versions of 8.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be… IDs: CVE-2018-7161 Record: https://patchnext.com/advisories/cve-2018-7161 (revision 2, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 10.4.1, 9.11.2, 8.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 8.0.0, < 8.11.3; >= 9.0.0, < 9.11.2; >= 10.0.0, < 10.4.1; fixed in 10.4.1, 8.11.3, 9.11.2 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2018-7161 to 2018-06-12.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/49.json (Node.js security working group core entry 49 lists CVE-2018-7161 affecting node >=8.0.0 =9.0.0 =10.0.0 <10.4.1) Commands are suggestions: review each one before running it.
Loading voting…