Skip to content

← Actionable
Unrated

The HTTP parser in all current versions of Node.js ignores spaces in the Content-Length header, allowing input such as Content-Length: 1 2 to be interpreted as having a value of 12. The HTTP…

CVE-2018-7159

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 9.10.0, 8.11.0, 6.14.0, 4.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 4.0.0, < 4.9.0>= 6.0.0, < 6.14.0>= 8.0.0, < 8.11.0>= 9.0.0, < 9.10.0
    Fixed in
    9.10.0, 8.11.0, 6.14.0, 4.9.0

Sources

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2018-7159 to 2018-03-28.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 47 lists CVE-2018-7159 affecting node >=4.0.0 =6.0.0 =8.0.0 =9.0.0 <9.10.0

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2018-7159: 3.54% estimated exploitation activity in the next 30 days; percentile 89.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The HTTP parser in all current versions of Node.js ignores spaces in the `Content-Length` header, allowing input such as `Content-Length: 1 2` to be interpreted as having a value of `12`. The HTTP specification does not allow for spaces in the `Content-Length` value and the Node.js HTTP parser has been brought into line on this particular difference. The security risk of this flaw to Node.js users is considered to be VERY LOW as it is difficult, and may be impossible, to craft an attack that makes use of this flaw in a way that could not already be achieved by supplying an incorrect value for `Content-Length`. Vulnerabilities may exist in user-code that make incorrect assumptions about the potential accuracy of this value compared to the actual length of the data supplied. Node.js users crafting lower-level HTTP utilities are advised to re-check the length of any input supplied after parsing is complete.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:47

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-7159

Advisory: The HTTP parser in all current versions of Node.js ignores spaces in the `Content-Length` header, allowing input such as `Content-Length: 1 2` to be interpreted as having a value of `12`. The HTTP…
IDs: CVE-2018-7159
Record: https://patchnext.com/advisories/cve-2018-7159 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 9.10.0, 8.11.0, 6.14.0, 4.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 4.0.0, < 4.9.0; >= 6.0.0, < 6.14.0; >= 8.0.0, < 8.11.0; >= 9.0.0, < 9.10.0; fixed in 9.10.0, 8.11.0, 6.14.0, 4.9.0

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2018-7159 to 2018-03-28.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/47.json (Node.js security working group core entry 47 lists CVE-2018-7159 affecting node >=4.0.0 =6.0.0 =8.0.0 =9.0.0 <9.10.0)

Commands are suggestions: review each one before running it.

Loading voting…