SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability
CVE-2018-6519GHSA-hhm8-2j4g-mpgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2 3.1.1, 2.3.5, 1.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/saml2
- Affected
- < 1.10.4>= 2.0, < 2.3.5>= 3.0, < 3.1.1
- Fixed in
- 3.1.1, 1.10.4, 2.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhm8-2j4g-mpgg lists affected ranges: Packagist simplesamlphp/saml2 >=0 =2.0 =3.0 <3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-6519: 1.70% estimated exploitation activity in the next 30 days; percentile 77.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hhm8-2j4g-mpgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-6519 Advisory: SimpleSAMLphp SAML2 library Regular Expression Denial of Service vulnerability IDs: CVE-2018-6519, GHSA-hhm8-2j4g-mpgg Record: https://patchnext.com/advisories/cve-2018-6519 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2 3.1.1, 2.3.5, 1.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/saml2: affected < 1.10.4; >= 2.0, < 2.3.5; >= 3.0, < 3.1.1; fixed in 3.1.1, 1.10.4, 2.3.5 ## Suggested inspection (read-only) - Packagist simplesamlphp/saml2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hhm8-2j4g-mpgg (GitHub-reviewed advisory GHSA-hhm8-2j4g-mpgg lists affected ranges: Packagist simplesamlphp/saml2 >=0 =2.0 =3.0 <3.1.1) Commands are suggestions: review each one before running it.
Loading voting…