Improper Certificate Validation in chloride
CVE-2018-6517GHSA-573x-jhqh-jg36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chloride 0.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems chloride
- Affected
- < 0.3.0
- Fixed in
- 0.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-573x-jhqh-jg36 lists affected ranges: RubyGems chloride >=0 <0.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-6517: 0.89% estimated exploitation activity in the next 30 days; percentile 59.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prior to version 0.3.0, chloride's use of net-ssh resulted in host fingerprints for previously unknown hosts getting added to the user's knownhosts file without confirmation. In version 0.3.0 this is updated so that the user's knownhosts file is not updated by chloride.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-573x-jhqh-jg36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-6517 Advisory: Improper Certificate Validation in chloride IDs: CVE-2018-6517, GHSA-573x-jhqh-jg36 Record: https://patchnext.com/advisories/cve-2018-6517 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chloride 0.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems chloride: affected < 0.3.0; fixed in 0.3.0 ## Suggested inspection (read-only) - RubyGems chloride: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chloride. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-573x-jhqh-jg36 (GitHub-reviewed advisory GHSA-573x-jhqh-jg36 lists affected ranges: RubyGems chloride >=0 <0.3.0) Commands are suggestions: review each one before running it.
Loading voting…