react-dev-utils on Windows vulnerable to Remote Code Execution
CVE-2018-6342GHSA-29gp-92wp-94q8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-dev-utils 5.0.2, 4.2.2, 3.1.2, 2.0.2, 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm react-dev-utils
- Affected
- >= 1.0.0, < 1.0.4>= 2.0.0, < 2.0.2>= 3.0.0, < 3.1.2>= 4.0.0, < 4.2.2>= 5.0.0, < 5.0.2
- Fixed in
- 1.0.4, 3.1.2, 2.0.2, 4.2.2, 5.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-29gp-92wp-94q8 lists affected ranges: npm react-dev-utils >=1.0.0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29gp-92wp-94q8 lists affected ranges: npm react-dev-utils >=1.0.0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2018-6342: 2.84% estimated exploitation activity in the next 30 days; percentile 86.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
react-dev-utils on Windows is vulnerable to remote code execution. Recommendation Update to one of the following versions, depending on the release line that you are using. - 1.0.4 - 2.0.2 - 3.1.2 - 4.2.2 - 5.0.2 - 6.0.0-next.a671462c
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-29gp-92wp-94q8
- Revision 1 · created ·
Published from osv record GHSA-29gp-92wp-94q8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-6342 Advisory: react-dev-utils on Windows vulnerable to Remote Code Execution IDs: CVE-2018-6342, GHSA-29gp-92wp-94q8 Record: https://patchnext.com/advisories/cve-2018-6342 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-dev-utils 5.0.2, 4.2.2, 3.1.2, 2.0.2, 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-dev-utils: affected >= 1.0.0, < 1.0.4; >= 2.0.0, < 2.0.2; >= 3.0.0, < 3.1.2; >= 4.0.0, < 4.2.2; >= 5.0.0, < 5.0.2; fixed in 1.0.4, 3.1.2, 2.0.2, 4.2.2, 5.0.2 ## Suggested inspection (read-only) - `npm ls react-dev-utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-dev-utils. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-29gp-92wp-94q8 (OSV record GHSA-29gp-92wp-94q8 lists affected ranges: npm react-dev-utils >=1.0.0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-29gp-92wp-94q8 (GitHub-reviewed advisory GHSA-29gp-92wp-94q8 lists affected ranges: npm react-dev-utils >=1.0.0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.0.2) Commands are suggestions: review each one before running it.
Loading voting…