Wizkunde SAMLBase SAML Bypass
CVE-2018-5387GHSA-7gh2-8q93-87hp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogentooss/samlbase 1.2.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist gogentooss/samlbase
- Affected
- < 1.2.7
- Fixed in
- 1.2.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7gh2-8q93-87hp lists affected ranges: Packagist gogentooss/samlbase >=0 <1.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-5387: 1.66% estimated exploitation activity in the next 30 days; percentile 76.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Wizkunde SAMLBase may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7gh2-8q93-87hp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-5387 Advisory: Wizkunde SAMLBase SAML Bypass IDs: CVE-2018-5387, GHSA-7gh2-8q93-87hp Record: https://patchnext.com/advisories/cve-2018-5387 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gogentooss/samlbase 1.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist gogentooss/samlbase: affected < 1.2.7; fixed in 1.2.7 ## Suggested inspection (read-only) - Packagist gogentooss/samlbase: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gogentooss/samlbase. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7gh2-8q93-87hp (GitHub-reviewed advisory GHSA-7gh2-8q93-87hp lists affected ranges: Packagist gogentooss/samlbase >=0 <1.2.7) Commands are suggestions: review each one before running it.
Loading voting…