Malicious PDF can inject JavaScript into PDF Viewer
CVE-2018-5158GHSA-7jg2-jgv3-fmr4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdfjs-dist 2.0.550, 1.10.100), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pdfjs-dist
- Affected
- >= 2.0.0, < 2.0.550< 1.10.100
- Fixed in
- 2.0.550, 1.10.100
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7jg2-jgv3-fmr4 lists affected ranges: npm pdfjs-dist >=2.0.0 =0 <1.10.100 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7jg2-jgv3-fmr4 lists affected ranges: npm pdfjs-dist >=2.0.0 =0 <1.10.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-5158: 10.24% estimated exploitation activity in the next 30 days; percentile 95.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8, Firefox < 60 and PDF.js < 2.0.550.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7jg2-jgv3-fmr4
- Revision 1 · created ·
Published from osv record GHSA-7jg2-jgv3-fmr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-5158 Advisory: Malicious PDF can inject JavaScript into PDF Viewer IDs: CVE-2018-5158, GHSA-7jg2-jgv3-fmr4 Record: https://patchnext.com/advisories/cve-2018-5158 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pdfjs-dist 2.0.550, 1.10.100. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pdfjs-dist: affected >= 2.0.0, < 2.0.550; < 1.10.100; fixed in 2.0.550, 1.10.100 ## Suggested inspection (read-only) - `npm ls pdfjs-dist --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pdfjs-dist. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7jg2-jgv3-fmr4 (OSV record GHSA-7jg2-jgv3-fmr4 lists affected ranges: npm pdfjs-dist >=2.0.0 =0 <1.10.100 (fixed)) - Verified: https://github.com/advisories/GHSA-7jg2-jgv3-fmr4 (GitHub-reviewed advisory GHSA-7jg2-jgv3-fmr4 lists affected ranges: npm pdfjs-dist >=2.0.0 =0 <1.10.100) Commands are suggestions: review each one before running it.
Loading voting…