Command Injection in egg-scripts
CVE-2018-3786GHSA-c9j3-wqph-5xx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (egg-scripts 2.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm egg-scripts
- Affected
- < 2.8.1
- Fixed in
- 2.8.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c9j3-wqph-5xx9 lists affected ranges: npm egg-scripts >=0 <2.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c9j3-wqph-5xx9 lists affected ranges: npm egg-scripts >=0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-3786: 12.28% estimated exploitation activity in the next 30 days; percentile 96.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of egg-scripts before 2.8.1 are vulnerable to command injection. This is only exploitable if a malicious argument is provided on the command line. Example: eggctl start --daemon --stderr='/tmp/eggctlstderr.log; touch /tmp/malicious' Recommendation Update to version 2.8.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c9j3-wqph-5xx9
- Revision 1 · created ·
Published from osv record GHSA-c9j3-wqph-5xx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-3786 Advisory: Command Injection in egg-scripts IDs: CVE-2018-3786, GHSA-c9j3-wqph-5xx9 Record: https://patchnext.com/advisories/cve-2018-3786 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: egg-scripts 2.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm egg-scripts: affected < 2.8.1; fixed in 2.8.1 ## Suggested inspection (read-only) - `npm ls egg-scripts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on egg-scripts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c9j3-wqph-5xx9 (OSV record GHSA-c9j3-wqph-5xx9 lists affected ranges: npm egg-scripts >=0 <2.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-c9j3-wqph-5xx9 (GitHub-reviewed advisory GHSA-c9j3-wqph-5xx9 lists affected ranges: npm egg-scripts >=0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…