Skip to content

← Actionable
Critical, CVSS 9.8amended

Prototype Pollution in deep-extend

CVE-2018-3750GHSA-hr2v-3952-633q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deep-extend 0.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-3750: 2.15% estimated exploitation activity in the next 30 days; percentile 82.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution. Recommendation Update to version 0.5.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hr2v-3952-633q

  2. Revision 1 · created ·

    Published from osv record GHSA-hr2v-3952-633q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-3750

Advisory: Prototype Pollution in deep-extend
IDs: CVE-2018-3750, GHSA-hr2v-3952-633q
Record: https://patchnext.com/advisories/cve-2018-3750 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deep-extend 0.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm deep-extend: affected < 0.5.1; fixed in 0.5.1

## Suggested inspection (read-only)
- `npm ls deep-extend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deep-extend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hr2v-3952-633q (OSV record GHSA-hr2v-3952-633q lists affected ranges: npm deep-extend >=0 <0.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hr2v-3952-633q (GitHub-reviewed advisory GHSA-hr2v-3952-633q lists affected ranges: npm deep-extend >=0 <0.5.1)

Commands are suggestions: review each one before running it.

Loading voting…