Sanitize vulnerable to Improper Input Validation and Cross-site Scripting
CVE-2018-3740GHSA-7f42-p84j-f58p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize 4.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sanitize
- Affected
- >= 3.0.0, < 4.6.3
- Fixed in
- 4.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7f42-p84j-f58p lists affected ranges: RubyGems sanitize >=3.0.0 <4.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-3740: 1.47% estimated exploitation activity in the next 30 days; percentile 73.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When Sanitize <= 4.6.2 is used in combination with libxml2 = 2.9.2, a specially crafted HTML fragment can cause libxml2 to generate improperly escaped output, allowing non-whitelisted attributes to be used on whitelisted elements. This can allow HTML and JavaScript injection, which could result in XSS if Sanitize's output is served to browsers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7f42-p84j-f58p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-3740 Advisory: Sanitize vulnerable to Improper Input Validation and Cross-site Scripting IDs: CVE-2018-3740, GHSA-7f42-p84j-f58p Record: https://patchnext.com/advisories/cve-2018-3740 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sanitize 4.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sanitize: affected >= 3.0.0, < 4.6.3; fixed in 4.6.3 ## Suggested inspection (read-only) - RubyGems sanitize: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sanitize. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7f42-p84j-f58p (GitHub-reviewed advisory GHSA-7f42-p84j-f58p lists affected ranges: RubyGems sanitize >=3.0.0 <4.6.3) Commands are suggestions: review each one before running it.
Loading voting…