Skip to content

← Actionable
High, CVSS 7.5amended

Path Traversal in stattic

CVE-2018-3734GHSA-w4pv-w56c-mg4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (stattic 0.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm stattic

    Affected
    < 0.3.0
    Fixed in
    0.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-3734: 1.89% estimated exploitation activity in the next 30 days; percentile 79.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of stattic before 0.3.0 are vulnerable to path traversal allowing a remote attacker to read arbitrary files with any extension from the server that users stattic. Recommendation Update to version 0.3.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w4pv-w56c-mg4v

  2. Revision 1 · created ·

    Published from osv record GHSA-w4pv-w56c-mg4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-3734

Advisory: Path Traversal in stattic
IDs: CVE-2018-3734, GHSA-w4pv-w56c-mg4v
Record: https://patchnext.com/advisories/cve-2018-3734 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: stattic 0.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm stattic: affected < 0.3.0; fixed in 0.3.0

## Suggested inspection (read-only)
- `npm ls stattic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on stattic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w4pv-w56c-mg4v (OSV record GHSA-w4pv-w56c-mg4v lists affected ranges: npm stattic >=0 <0.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w4pv-w56c-mg4v (GitHub-reviewed advisory GHSA-w4pv-w56c-mg4v lists affected ranges: npm stattic >=0 <0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…