Prototype Pollution in hoek
CVE-2018-3728GHSA-jp4x-w63m-7wgm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hoek 5.0.3, 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm hoek
- Affected
- >= 5.0.0, < 5.0.3< 4.2.1
- Fixed in
- 4.2.1, 5.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jp4x-w63m-7wgm lists affected ranges: npm hoek >=5.0.0 =0 <4.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jp4x-w63m-7wgm lists affected ranges: npm hoek >=5.0.0 =0 <4.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-3728: 4.19% estimated exploitation activity in the next 30 days; percentile 90.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of hoek prior to 4.2.1 and 5.0.3 are vulnerable to prototype pollution. The merge function, and the applyToDefaults and applyToDefaultsWithShallow functions which leverage merge behind the scenes, are vulnerable to a prototype pollution attack when provided an unvalidated payload created from a JSON string containing the proto property. This can be demonstrated like so: This type of attack can be used to overwrite existing properties causing a potential denial of service. Recommendation Update to version 4.2.1, 5.0.3 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jp4x-w63m-7wgm
- Revision 1 · created ·
Published from osv record GHSA-jp4x-w63m-7wgm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-3728 Advisory: Prototype Pollution in hoek IDs: CVE-2018-3728, GHSA-jp4x-w63m-7wgm Record: https://patchnext.com/advisories/cve-2018-3728 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hoek 5.0.3, 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hoek: affected >= 5.0.0, < 5.0.3; < 4.2.1; fixed in 4.2.1, 5.0.3 ## Suggested inspection (read-only) - `npm ls hoek --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hoek. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jp4x-w63m-7wgm (OSV record GHSA-jp4x-w63m-7wgm lists affected ranges: npm hoek >=5.0.0 =0 <4.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jp4x-w63m-7wgm (GitHub-reviewed advisory GHSA-jp4x-w63m-7wgm lists affected ranges: npm hoek >=5.0.0 =0 <4.2.1) Commands are suggestions: review each one before running it.
Loading voting…