Path Traversal in angular-http-server
CVE-2018-3713GHSA-4rvg-955w-h68q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular-http-server 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4rvg-955w-h68q lists affected ranges: npm angular-http-server >=0 <1.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rvg-955w-h68q lists affected ranges: npm angular-http-server >=0 <1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-3713: 1.45% estimated exploitation activity in the next 30 days; percentile 73.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of angular-http-server are vulnerable to path traversal allowing a remote attacker to read files from the server that uses angular-http-server. Recommendation Update to version 1.6.0 or later. :exclamation: Note: This was originally thought to be fixed in version 1.4.3, though according to this issue the vulnerability was not completely fixed until version 1.6.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4rvg-955w-h68q
- Revision 1 · created ·
Published from osv record GHSA-4rvg-955w-h68q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-3713 Advisory: Path Traversal in angular-http-server IDs: CVE-2018-3713, GHSA-4rvg-955w-h68q Record: https://patchnext.com/advisories/cve-2018-3713 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular-http-server 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular-http-server: affected < 1.6.0; fixed in 1.6.0 ## Suggested inspection (read-only) - `npm ls angular-http-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular-http-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4rvg-955w-h68q (OSV record GHSA-4rvg-955w-h68q lists affected ranges: npm angular-http-server >=0 <1.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4rvg-955w-h68q (GitHub-reviewed advisory GHSA-4rvg-955w-h68q lists affected ranges: npm angular-http-server >=0 <1.6.0) Commands are suggestions: review each one before running it.
Loading voting…