Skip to content

← Actionable
High, CVSS 7.5amended

rgb2hex vulnerable to inefficient regular expression complexity

CVE-2018-25061GHSA-7599-fqgm-v84p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rgb2hex 0.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm rgb2hex

    Affected
    < 0.1.6
    Fixed in
    0.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-25061: 1.03% estimated exploitation activity in the next 30 days; percentile 63.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in rgb2hex up to 0.1.5. It has been rated as problematic. This issue affects some unknown processing. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 0.1.6 can address this issue. The name of the patch is 9e0c38594432edfa64136fdf7bb651835e17c34f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217151.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7599-fqgm-v84p

  2. Revision 1 · created ·

    Published from osv record GHSA-7599-fqgm-v84p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-25061

Advisory: rgb2hex vulnerable to inefficient regular expression complexity
IDs: CVE-2018-25061, GHSA-7599-fqgm-v84p
Record: https://patchnext.com/advisories/cve-2018-25061 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rgb2hex 0.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm rgb2hex: affected < 0.1.6; fixed in 0.1.6

## Suggested inspection (read-only)
- `npm ls rgb2hex --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rgb2hex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7599-fqgm-v84p (OSV record GHSA-7599-fqgm-v84p lists affected ranges: npm rgb2hex >=0 <0.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-7599-fqgm-v84p (GitHub-reviewed advisory GHSA-7599-fqgm-v84p lists affected ranges: npm rgb2hex >=0 <0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…