Twitter-Post-Fetcher vulnerable to Use of Web Link to Untrusted Target with window.opener Access
CVE-2018-25058GHSA-m688-cx2p-rgq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twitter-fetcher-js 18.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 18.0.0
- Fixed in
- 18.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m688-cx2p-rgq9 lists affected ranges: npm twitter-fetcher-js >=0 <18.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m688-cx2p-rgq9 lists affected ranges: npm twitter-fetcher-js >=0 <18.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-25058: 0.56% estimated exploitation activity in the next 30 days; percentile 46.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability classified as problematic has been found in Twitter-Post-Fetcher up to 17.x. This affects an unknown part of the file js/twitterFetcher.js of the component Link Target Handler. The manipulation leads to use of web link to untrusted target with window.opener access. It is possible to initiate the attack remotely. Upgrading to version 18.0.0 can address this issue. The name of the patch is 7d281c6fb5acbc29a2cad295262c1f0c19ca56f3. It is recommended to upgrade the affected component. The identifier VDB-217017 was assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m688-cx2p-rgq9
- Revision 1 · created ·
Published from osv record GHSA-m688-cx2p-rgq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-25058 Advisory: Twitter-Post-Fetcher vulnerable to Use of Web Link to Untrusted Target with window.opener Access IDs: CVE-2018-25058, GHSA-m688-cx2p-rgq9 Record: https://patchnext.com/advisories/cve-2018-25058 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: twitter-fetcher-js 18.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm twitter-fetcher-js: affected < 18.0.0; fixed in 18.0.0 ## Suggested inspection (read-only) - `npm ls twitter-fetcher-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on twitter-fetcher-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m688-cx2p-rgq9 (OSV record GHSA-m688-cx2p-rgq9 lists affected ranges: npm twitter-fetcher-js >=0 <18.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m688-cx2p-rgq9 (GitHub-reviewed advisory GHSA-m688-cx2p-rgq9 lists affected ranges: npm twitter-fetcher-js >=0 <18.0.0) Commands are suggestions: review each one before running it.
Loading voting…