Skip to content

← Actionable
Medium, CVSS 5.4

Smarty Cross-site Scripting vulnerability in pages that use smarty_function_mailto

CVE-2018-25047GHSA-hwq7-5vv9-c6cf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 4.2.1, 3.1.47), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist smarty/smarty

    Affected
    < 3.1.47>= 4.0.0, < 4.2.1
    Fixed in
    4.2.1, 3.1.47

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-25047: 1.10% estimated exploitation activity in the next 30 days; percentile 65.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows cross-site scripting. A web page that uses smartyfunctionmailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hwq7-5vv9-c6cf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-25047

Advisory: Smarty Cross-site Scripting vulnerability in pages that use smarty_function_mailto
IDs: CVE-2018-25047, GHSA-hwq7-5vv9-c6cf
Record: https://patchnext.com/advisories/cve-2018-25047 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 4.2.1, 3.1.47. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist smarty/smarty: affected < 3.1.47; >= 4.0.0, < 4.2.1; fixed in 4.2.1, 3.1.47

## Suggested inspection (read-only)
- Packagist smarty/smarty: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smarty/smarty.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hwq7-5vv9-c6cf (GitHub-reviewed advisory GHSA-hwq7-5vv9-c6cf lists affected ranges: Packagist smarty/smarty >=0 =4.0.0 <4.2.1)

Commands are suggestions: review each one before running it.

Loading voting…