Spoofing attack in swagger-ui
CVE-2018-25031GHSA-cr3q-pqgq-m8c2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.webjars:swagger-ui 4.1.3; swagger-ui 4.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.webjars:swagger-ui
- Affected
- < 4.1.3
- Fixed in
- 4.1.3
npm swagger-ui
- Affected
- < 4.1.3
- Fixed in
- 4.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cr3q-pqgq-m8c2 lists affected ranges: npm swagger-ui >=0 =0 <4.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cr3q-pqgq-m8c2 lists affected ranges: npm swagger-ui >=0 =0 <4.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2018-25031: 42.33% estimated exploitation activity in the next 30 days; percentile 98.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cr3q-pqgq-m8c2
- Revision 1 · created ·
Published from osv record GHSA-cr3q-pqgq-m8c2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-25031 Advisory: Spoofing attack in swagger-ui IDs: CVE-2018-25031, GHSA-cr3q-pqgq-m8c2 Record: https://patchnext.com/advisories/cve-2018-25031 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.webjars:swagger-ui 4.1.3; swagger-ui 4.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.webjars:swagger-ui: affected < 4.1.3; fixed in 4.1.3 - npm swagger-ui: affected < 4.1.3; fixed in 4.1.3 ## Suggested inspection (read-only) - Maven org.webjars:swagger-ui: check the installed version with your package manager. - `npm ls swagger-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.webjars:swagger-ui, swagger-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cr3q-pqgq-m8c2 (OSV record GHSA-cr3q-pqgq-m8c2 lists affected ranges: npm swagger-ui >=0 =0 <4.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-cr3q-pqgq-m8c2 (GitHub-reviewed advisory GHSA-cr3q-pqgq-m8c2 lists affected ranges: npm swagger-ui >=0 =0 <4.1.3) Commands are suggestions: review each one before running it.
Loading voting…