Skip to content

← Actionable
Critical, CVSS 9.8

Out-of-bounds Write in actix-web

CVE-2018-25024GHSA-9qj6-4rfq-vm84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actix-web 0.7.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io actix-web

    Affected
    < 0.7.19
    Fixed in
    0.7.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-25024: 1.33% estimated exploitation activity in the next 30 days; percentile 71.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the actix-web crate before 0.7.19 for Rust. It can unsoundly coerce an immutable reference into a mutable reference, leading to memory corruption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9qj6-4rfq-vm84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-25024

Advisory: Out-of-bounds Write in actix-web
IDs: CVE-2018-25024, GHSA-9qj6-4rfq-vm84
Record: https://patchnext.com/advisories/cve-2018-25024 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actix-web 0.7.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io actix-web: affected < 0.7.19; fixed in 0.7.19

## Suggested inspection (read-only)
- crates.io actix-web: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actix-web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9qj6-4rfq-vm84 (GitHub-reviewed advisory GHSA-9qj6-4rfq-vm84 lists affected ranges: crates.io actix-web >=0 <0.7.19)

Commands are suggestions: review each one before running it.

Loading voting…