Out-of-bounds Read in stringstream
CVE-2018-21270GHSA-mf6x-7mm4-x2g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (stringstream 0.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm stringstream
- Affected
- < 0.0.6
- Fixed in
- 0.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mf6x-7mm4-x2g7 lists affected ranges: npm stringstream >=0 <0.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mf6x-7mm4-x2g7 lists affected ranges: npm stringstream >=0 <0.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2018-21270: 3.68% estimated exploitation activity in the next 30 days; percentile 89.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
All versions of stringstream are vulnerable to out-of-bounds read as it allocates uninitialized Buffers when number is passed in input stream on Node.js 4.x and below. Recommendation No fix is currently available for this vulnerability. It is our recommendation to not install or use this module if user input is being passed in to stringstream.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mf6x-7mm4-x2g7
- Revision 1 · created ·
Published from osv record GHSA-mf6x-7mm4-x2g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-21270 Advisory: Out-of-bounds Read in stringstream IDs: CVE-2018-21270, GHSA-mf6x-7mm4-x2g7 Record: https://patchnext.com/advisories/cve-2018-21270 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: stringstream 0.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm stringstream: affected < 0.0.6; fixed in 0.0.6 ## Suggested inspection (read-only) - `npm ls stringstream --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on stringstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mf6x-7mm4-x2g7 (OSV record GHSA-mf6x-7mm4-x2g7 lists affected ranges: npm stringstream >=0 <0.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-mf6x-7mm4-x2g7 (GitHub-reviewed advisory GHSA-mf6x-7mm4-x2g7 lists affected ranges: npm stringstream >=0 <0.0.6) Commands are suggestions: review each one before running it.
Loading voting…