Regular Expression Denial of Service in highcharts
CVE-2018-20801GHSA-xmc8-cjfr-phx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 6.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm highcharts
- Affected
- < 6.1.0
- Fixed in
- 6.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xmc8-cjfr-phx3 lists affected ranges: npm highcharts >=0 <6.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xmc8-cjfr-phx3 lists affected ranges: npm highcharts >=0 <6.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-20801: 3.17% estimated exploitation activity in the next 30 days; percentile 88.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of highcharts prior to 6.1.0 are vulnerable to Regular Expression Denial of Service (ReDoS). Untrusted input may cause catastrophic backtracking while matching regular expressions. This can cause the application to be unresponsive leading to Denial of Service. Recommendation Upgrade to version 6.1.0 or higher.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xmc8-cjfr-phx3
- Revision 1 · created ·
Published from osv record GHSA-xmc8-cjfr-phx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-20801 Advisory: Regular Expression Denial of Service in highcharts IDs: CVE-2018-20801, GHSA-xmc8-cjfr-phx3 Record: https://patchnext.com/advisories/cve-2018-20801 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: highcharts 6.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm highcharts: affected < 6.1.0; fixed in 6.1.0 ## Suggested inspection (read-only) - `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on highcharts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xmc8-cjfr-phx3 (OSV record GHSA-xmc8-cjfr-phx3 lists affected ranges: npm highcharts >=0 <6.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xmc8-cjfr-phx3 (GitHub-reviewed advisory GHSA-xmc8-cjfr-phx3 lists affected ranges: npm highcharts >=0 <6.1.0) Commands are suggestions: review each one before running it.
Loading voting…