Skip to content

← Actionable
High, CVSS 8.8

PrestaShop PHP Object Injection

CVE-2018-20717GHSA-xx67-2j3v-h76p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 1.7.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-20717: 2.69% estimated exploitation activity in the next 30 days; percentile 85.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xx67-2j3v-h76p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-20717

Advisory: PrestaShop PHP Object Injection
IDs: CVE-2018-20717, GHSA-xx67-2j3v-h76p
Record: https://patchnext.com/advisories/cve-2018-20717 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 1.7.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist prestashop/prestashop: affected < 1.7.2.5; fixed in 1.7.2.5

## Suggested inspection (read-only)
- Packagist prestashop/prestashop: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on prestashop/prestashop.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xx67-2j3v-h76p (GitHub-reviewed advisory GHSA-xx67-2j3v-h76p lists affected ranges: Packagist prestashop/prestashop >=0 <1.7.2.5)

Commands are suggestions: review each one before running it.

Loading voting…