Skip to content

← Actionable
Medium, CVSS 5.3amended

uap-core Regular Expression Denial of Service issue

CVE-2018-20164GHSA-fx7m-j728-mjw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uap-core 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm uap-core

    Affected
    < 0.6.0
    Fixed in
    0.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2018-20164: 3.30% estimated exploitation activity in the next 30 days; percentile 88.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in regex.yaml (aka regexes.yaml) in UA-Parser UAP-Core before 0.6.0. A Regular Expression Denial of Service (ReDoS) issue allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to a value containing a long digit string. (The UAP-Core project contains the vulnerability, propagating to all implementations.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fx7m-j728-mjw3

  2. Revision 1 · created ·

    Published from osv record GHSA-fx7m-j728-mjw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-20164

Advisory: uap-core Regular Expression Denial of Service issue
IDs: CVE-2018-20164, GHSA-fx7m-j728-mjw3
Record: https://patchnext.com/advisories/cve-2018-20164 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uap-core 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uap-core: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- `npm ls uap-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uap-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fx7m-j728-mjw3 (OSV record GHSA-fx7m-j728-mjw3 lists affected ranges: npm uap-core >=0 <0.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fx7m-j728-mjw3 (GitHub-reviewed advisory GHSA-fx7m-j728-mjw3 lists affected ranges: npm uap-core >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…