Improper Restriction of XML External Entity Reference in bedework:bw-webdav
CVE-2018-20000GHSA-5p52-j8pw-j7x5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bedework:bw-webdav 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bedework:bw-webdav
- Affected
- >= 4.0.1, < 4.0.3
- Fixed in
- 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p52-j8pw-j7x5 lists affected ranges: Maven org.bedework:bw-webdav >=4.0.1 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-20000: 1.69% estimated exploitation activity in the next 30 days; percentile 77.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apereo Bedework bw-webdav before 4.0.3 allows XXE attacks, as demonstrated by an invite-reply document that reads a local file, related to webdav/servlet/common/MethodBase.java and webdav/servlet/common/PostRequestPars.java.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5p52-j8pw-j7x5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-20000 Advisory: Improper Restriction of XML External Entity Reference in bedework:bw-webdav IDs: CVE-2018-20000, GHSA-5p52-j8pw-j7x5 Record: https://patchnext.com/advisories/cve-2018-20000 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bedework:bw-webdav 4.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bedework:bw-webdav: affected >= 4.0.1, < 4.0.3; fixed in 4.0.3 ## Suggested inspection (read-only) - Maven org.bedework:bw-webdav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bedework:bw-webdav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5p52-j8pw-j7x5 (GitHub-reviewed advisory GHSA-5p52-j8pw-j7x5 lists affected ranges: Maven org.bedework:bw-webdav >=4.0.1 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…