Jenkins TraceTronic ECU-TEST Plugin Man in the middle vulnerability
CVE-2018-1999025GHSA-w86j-99wg-r29f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (de.tracetronic.jenkins.plugins:ecutest 2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven de.tracetronic.jenkins.plugins:ecutest
- Affected
- <= 2.3
- Fixed in
- 2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w86j-99wg-r29f lists affected ranges: Maven de.tracetronic.jenkins.plugins:ecutest >=0 <=2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2018-1999025: 0.86% estimated exploitation activity in the next 30 days; percentile 58.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A man in the middle vulnerability exists in Jenkins TraceTronic ECU-TEST Plugin 2.3 and earlier in ATXPublisher.java, ATXValidator.java that allows attackers to impersonate any service that Jenkins connects to.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w86j-99wg-r29f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1999025 Advisory: Jenkins TraceTronic ECU-TEST Plugin Man in the middle vulnerability IDs: CVE-2018-1999025, GHSA-w86j-99wg-r29f Record: https://patchnext.com/advisories/cve-2018-1999025 (revision 1, source checked 26 Oct 2026, 16:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: de.tracetronic.jenkins.plugins:ecutest 2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven de.tracetronic.jenkins.plugins:ecutest: affected <= 2.3; fixed in 2.4 ## Suggested inspection (read-only) - Maven de.tracetronic.jenkins.plugins:ecutest: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on de.tracetronic.jenkins.plugins:ecutest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w86j-99wg-r29f (GitHub-reviewed advisory GHSA-w86j-99wg-r29f lists affected ranges: Maven de.tracetronic.jenkins.plugins:ecutest >=0 <=2.3) Commands are suggestions: review each one before running it.
Loading voting…