Skip to content

← Actionable
High, CVSS 8.8

phpMyAdmin CSRF Vulnerability

CVE-2018-19969GHSA-xwf2-53mc-r8hx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-19969: 1.06% estimated exploitation activity in the next 30 days; percentile 64.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xwf2-53mc-r8hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-19969

Advisory: phpMyAdmin CSRF Vulnerability
IDs: CVE-2018-19969, GHSA-xwf2-53mc-r8hx
Record: https://patchnext.com/advisories/cve-2018-19969 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpmyadmin/phpmyadmin 4.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.8, < 4.8.4; >= 4.7, <= 4.7.6; fixed in 4.8.4

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xwf2-53mc-r8hx (GitHub-reviewed advisory GHSA-xwf2-53mc-r8hx lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.8 =4.7 <=4.7.6)

Commands are suggestions: review each one before running it.

Loading voting…