Skip to content

← Actionable
Medium, CVSS 6.1

Bolt Cross-site Scripting (XSS) via text input click preview button

CVE-2018-19933GHSA-gjx6-58xh-p7pw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bolt/bolt 3.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist bolt/bolt

    Affected
    < 3.6.2
    Fixed in
    3.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-19933: 3.47% estimated exploitation activity in the next 30 days; percentile 89.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Bolt CMS <3.6.2 allows XSS via text input click preview button as demonstrated by the Title field of a Configured and New Entry.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gjx6-58xh-p7pw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-19933

Advisory: Bolt Cross-site Scripting (XSS) via text input click preview button
IDs: CVE-2018-19933, GHSA-gjx6-58xh-p7pw
Record: https://patchnext.com/advisories/cve-2018-19933 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bolt/bolt 3.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bolt/bolt: affected < 3.6.2; fixed in 3.6.2

## Suggested inspection (read-only)
- Packagist bolt/bolt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bolt/bolt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gjx6-58xh-p7pw (GitHub-reviewed advisory GHSA-gjx6-58xh-p7pw lists affected ranges: Packagist bolt/bolt >=0 <3.6.2)

Commands are suggestions: review each one before running it.

Loading voting…