Skip to content

← Actionable
Medium, CVSS 5.1amended

Jupyter Notebook XSS via directory name

CVE-2018-19352GHSA-3p4q-x8f3-p7vq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (notebook 5.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI notebook

    Affected
    < 5.7.2
    Fixed in
    5.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2018-19352: 1.33% estimated exploitation activity in the next 30 days; percentile 71.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jupyter Notebook before 5.7.2 allows XSS via a crafted directory name because notebook/static/tree/js/notebooklist.js handles certain URLs unsafely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3p4q-x8f3-p7vq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3p4q-x8f3-p7vq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-19352

Advisory: Jupyter Notebook XSS via directory name
IDs: CVE-2018-19352, GHSA-3p4q-x8f3-p7vq
Record: https://patchnext.com/advisories/cve-2018-19352 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: notebook 5.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI notebook: affected < 5.7.2; fixed in 5.7.2

## Suggested inspection (read-only)
- `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on notebook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3p4q-x8f3-p7vq (OSV record GHSA-3p4q-x8f3-p7vq lists affected ranges: PyPI notebook >=0 <5.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-3p4q-x8f3-p7vq (GitHub-reviewed advisory GHSA-3p4q-x8f3-p7vq lists affected ranges: PyPI notebook >=0 <5.7.2)

Commands are suggestions: review each one before running it.

Loading voting…