Centreon allows SNMP trap SQL Injection
CVE-2018-19281GHSA-w2xf-4gg9-87wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (centreon/centreon 18.10.0, 2.8.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist centreon/centreon
- Affected
- >= 18.0.0, < 18.10.0>= 2.8, < 2.8.27
- Fixed in
- 18.10.0, 2.8.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w2xf-4gg9-87wr lists affected ranges: Packagist centreon/centreon >=18.0.0 =2.8 <2.8.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-19281: 1.76% estimated exploitation activity in the next 30 days; percentile 78.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Centreon 3.4.x (fixed in Centreon 18.10.0 and Centreon web 2.8.27) allows SNMP trap SQL Injection.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w2xf-4gg9-87wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-19281 Advisory: Centreon allows SNMP trap SQL Injection IDs: CVE-2018-19281, GHSA-w2xf-4gg9-87wr Record: https://patchnext.com/advisories/cve-2018-19281 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: centreon/centreon 18.10.0, 2.8.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist centreon/centreon: affected >= 18.0.0, < 18.10.0; >= 2.8, < 2.8.27; fixed in 18.10.0, 2.8.27 ## Suggested inspection (read-only) - Packagist centreon/centreon: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on centreon/centreon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w2xf-4gg9-87wr (GitHub-reviewed advisory GHSA-w2xf-4gg9-87wr lists affected ranges: Packagist centreon/centreon >=18.0.0 =2.8 <2.8.27) Commands are suggestions: review each one before running it.
Loading voting…