phpBB Remote Code Execution
CVE-2018-19274GHSA-h3mr-q96r-37v4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpbb/phpbb 3.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpbb/phpbb
- Affected
- < 3.2.4
- Fixed in
- 3.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h3mr-q96r-37v4 lists affected ranges: Packagist phpbb/phpbb >=0 <3.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-19274: 5.20% estimated exploitation activity in the next 30 days; percentile 92.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Passing an absolute path to a fileexists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h3mr-q96r-37v4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-19274 Advisory: phpBB Remote Code Execution IDs: CVE-2018-19274, GHSA-h3mr-q96r-37v4 Record: https://patchnext.com/advisories/cve-2018-19274 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpbb/phpbb 3.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpbb/phpbb: affected < 3.2.4; fixed in 3.2.4 ## Suggested inspection (read-only) - Packagist phpbb/phpbb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpbb/phpbb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h3mr-q96r-37v4 (GitHub-reviewed advisory GHSA-h3mr-q96r-37v4 lists affected ranges: Packagist phpbb/phpbb >=0 <3.2.4) Commands are suggestions: review each one before running it.
Loading voting…