Caddy allows enumeration of Certificates and Hostnames
CVE-2018-19148GHSA-jf2w-mq6r-56v8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/caddyserver/caddy 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/caddyserver/caddy
- Affected
- < 0.11.1
- Fixed in
- 0.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf2w-mq6r-56v8 lists affected ranges: Go github.com/caddyserver/caddy >=0 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2018-19148: 0.86% estimated exploitation activity in the next 30 days; percentile 58.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Caddy through 0.11.0 sends incorrect certificates for certain invalid requests, making it easier for attackers to enumerate hostnames. Specifically, when unable to match a Host header with a vhost in its configuration, it serves the X.509 certificate for a randomly selected vhost in its configuration. Repeated requests (with a nonexistent hostname in the Host header) permit full enumeration of all certificates on the server. This generally permits an attacker to easily and accurately discover the existence of and relationships among hostnames that weren't meant to be public, though this information could likely have been discovered via other methods with additional effort.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jf2w-mq6r-56v8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-19148 Advisory: Caddy allows enumeration of Certificates and Hostnames IDs: CVE-2018-19148, GHSA-jf2w-mq6r-56v8 Record: https://patchnext.com/advisories/cve-2018-19148 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/caddyserver/caddy 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/caddyserver/caddy: affected < 0.11.1; fixed in 0.11.1 ## Suggested inspection (read-only) - Go github.com/caddyserver/caddy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/caddyserver/caddy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jf2w-mq6r-56v8 (GitHub-reviewed advisory GHSA-jf2w-mq6r-56v8 lists affected ranges: Go github.com/caddyserver/caddy >=0 <0.11.1) Commands are suggestions: review each one before running it.
Loading voting…