Ckeditor XSS Vulnerability
CVE-2018-17960GHSA-g68x-vvqq-pvw3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor 4.11.0; typo3/cms-core 9.5.2, 8.7.21; typo3/cms 9.5.2, 8.7.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor
- Affected
- < 4.11.0
- Fixed in
- 4.11.0
Packagist typo3/cms-core
- Affected
- >= 8.0.0, < 8.7.21>= 9.0.0, < 9.5.2
- Fixed in
- 8.7.21, 9.5.2
Packagist typo3/cms
- Affected
- >= 8.0.0, < 8.7.21>= 9.0.0, < 9.5.2
- Fixed in
- 8.7.21, 9.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g68x-vvqq-pvw3 lists affected ranges: npm ckeditor >=0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g68x-vvqq-pvw3 lists affected ranges: npm ckeditor >=0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-17960: 1.95% estimated exploitation activity in the next 30 days; percentile 80.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste. It was possible to execute XSS inside the CKEditor source area after persuading the victim to: (i) switch CKEditor to source mode, then (ii) paste a specially crafted HTML code, prepared by the attacker, into the opened CKEditor source area, and (iii) switch back to WYSIWYG mode. Although this is an unlikely scenario, it is recommended to upgrade to the latest editor version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g68x-vvqq-pvw3
- Revision 1 · created ·
Published from osv record GHSA-g68x-vvqq-pvw3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-17960 Advisory: Ckeditor XSS Vulnerability IDs: CVE-2018-17960, GHSA-g68x-vvqq-pvw3 Record: https://patchnext.com/advisories/cve-2018-17960 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor 4.11.0; typo3/cms-core 9.5.2, 8.7.21; typo3/cms 9.5.2, 8.7.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor: affected < 4.11.0; fixed in 4.11.0 - Packagist typo3/cms-core: affected >= 8.0.0, < 8.7.21; >= 9.0.0, < 9.5.2; fixed in 8.7.21, 9.5.2 - Packagist typo3/cms: affected >= 8.0.0, < 8.7.21; >= 9.0.0, < 9.5.2; fixed in 8.7.21, 9.5.2 ## Suggested inspection (read-only) - `npm ls ckeditor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Packagist typo3/cms-core: check the installed version with your package manager. - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor, typo3/cms-core, typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g68x-vvqq-pvw3 (OSV record GHSA-g68x-vvqq-pvw3 lists affected ranges: npm ckeditor >=0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-g68x-vvqq-pvw3 (GitHub-reviewed advisory GHSA-g68x-vvqq-pvw3 lists affected ranges: npm ckeditor >=0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 <9.5.2) Commands are suggestions: review each one before running it.
Loading voting…