Cross-site Scripting in yapi-vendor
CVE-2018-17574GHSA-5xgh-643p-cp2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yapi-vendor 1.3.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm yapi-vendor
- Affected
- < 1.3.23
- Fixed in
- 1.3.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5xgh-643p-cp2g lists affected ranges: npm yapi-vendor >=0 <1.3.23 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xgh-643p-cp2g lists affected ranges: npm yapi-vendor >=0 <1.3.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-17574: 0.67% estimated exploitation activity in the next 30 days; percentile 51.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5xgh-643p-cp2g
- Revision 1 · created ·
Published from osv record GHSA-5xgh-643p-cp2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-17574 Advisory: Cross-site Scripting in yapi-vendor IDs: CVE-2018-17574, GHSA-5xgh-643p-cp2g Record: https://patchnext.com/advisories/cve-2018-17574 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yapi-vendor 1.3.23. A vendor fix does not mean a deployment is fixed. ## Affected components - npm yapi-vendor: affected < 1.3.23; fixed in 1.3.23 ## Suggested inspection (read-only) - `npm ls yapi-vendor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yapi-vendor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5xgh-643p-cp2g (OSV record GHSA-5xgh-643p-cp2g lists affected ranges: npm yapi-vendor >=0 <1.3.23 (fixed)) - Verified: https://github.com/advisories/GHSA-5xgh-643p-cp2g (GitHub-reviewed advisory GHSA-5xgh-643p-cp2g lists affected ranges: npm yapi-vendor >=0 <1.3.23) Commands are suggestions: review each one before running it.
Loading voting…