Cleartext Transmission of Sensitive Information in Apache nifi
CVE-2018-17195GHSA-3jq8-jg75-rqv6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.nifi:nifi
- Affected
- >= 1.0.0, <= 1.7.1
- Fixed in
- 1.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3jq8-jg75-rqv6 lists affected ranges: Maven org.apache.nifi:nifi >=1.0.0 <=1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-17195: 0.71% estimated exploitation activity in the next 30 days; percentile 53.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The template upload API endpoint accepted requests from different domain when sent in conjunction with ARP spoofing + man in the middle (MiTM) attack, resulting in a CSRF attack. The required attack vector is complex, requiring a scenario with client certificate authentication, same subnet access, and injecting malicious code into an unprotected (plaintext HTTP) website which the targeted user later visits, but the possible damage warranted a Severe severity level. Mitigation: The fix to apply Cross-Origin Resource Sharing (CORS) policy request filtering was applied on the Apache NiFi 1.8.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3jq8-jg75-rqv6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-17195 Advisory: Cleartext Transmission of Sensitive Information in Apache nifi IDs: CVE-2018-17195, GHSA-3jq8-jg75-rqv6 Record: https://patchnext.com/advisories/cve-2018-17195 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.nifi:nifi: affected >= 1.0.0, <= 1.7.1; fixed in 1.8.0 ## Suggested inspection (read-only) - Maven org.apache.nifi:nifi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.nifi:nifi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3jq8-jg75-rqv6 (GitHub-reviewed advisory GHSA-3jq8-jg75-rqv6 lists affected ranges: Maven org.apache.nifi:nifi >=1.0.0 <=1.7.1) Commands are suggestions: review each one before running it.
Loading voting…