Skip to content

← Actionable
High, CVSS 7.5

Apache NiFi Improper Input Validation vulnerability

CVE-2018-17194GHSA-43fp-vwwg-qgv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi-framework-cluster 1.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-17194: 2.97% estimated exploitation activity in the next 30 days; percentile 87.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When a client request to a cluster node was replicated to other nodes in the cluster for verification, the Content-Length was forwarded. On a DELETE request, the body was ignored, but if the initial request had a Content-Length value other than 0, the receiving nodes would wait for the body and eventually timeout. Mitigation: The fix to check DELETE requests and overwrite non-zero Content-Length header values was applied on the Apache NiFi 1.8.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43fp-vwwg-qgv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-17194

Advisory: Apache NiFi Improper Input Validation vulnerability
IDs: CVE-2018-17194, GHSA-43fp-vwwg-qgv6
Record: https://patchnext.com/advisories/cve-2018-17194 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi-framework-cluster 1.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.nifi:nifi-framework-cluster: affected >= 1.0.0, <= 1.7.1; fixed in 1.8.0

## Suggested inspection (read-only)
- Maven org.apache.nifi:nifi-framework-cluster: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.nifi:nifi-framework-cluster.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43fp-vwwg-qgv6 (GitHub-reviewed advisory GHSA-43fp-vwwg-qgv6 lists affected ranges: Maven org.apache.nifi:nifi-framework-cluster >=1.0.0 <=1.7.1)

Commands are suggestions: review each one before running it.

Loading voting…